Now there's a bit of an anticlimax – I WAS going to write about all the funky stuff that's been going on lately – new job, Motorhead gig last week, seeing The Producers on Wednesday night… But then something has to happen that just buggers the whole thing.

I got up this morning to check my mail before popping over to the post office to collect some eBay stuff I'd bought, but when I looked at my laptop screen, it was blank. I went to power it up, and there was a buzzy sound coming out of it – typically that kind of thing is the CPU fan, which I'd only recently had replaced, so I was a bit cranky to hear that.

The screen came up with its typical “IDE 1 Error”, which happens because I'm using a non-standard DVD burner in the modular bay, but like I said, that's normal. The buzzing stopped, then started again, and then a few seconds later another error flashed up on screen – IDE 0 Error.

I went to see if I could listen to my laptop to see where exactly the buzzing was coming from (HOPEFULLY not the hard drive !), but as I tilted it there was a kind of screeching sound. As I put it flat again, the buzzing continued, and my fingertips could feel the vibrations coming from the harddrive.

So yeah, it's dead.

AAAAAAAAAAAAAAAAAAAAAAAARRRRRRGGGGGHHHHHHHHH!!!!!!!!!!!!!

What the hell's going on ? Is there some conspiracy ? Am I over dramatising, or am I just genuinely having a really bad run ? It's possibly a little hard for non-computer folk to understand the impact of a dead hard drive, but think of it like this – ALL my data is now irretrievably lost. All my original photos (the pre-cut down versions of what's in my gallery), all my archived email (at least the last year's worth), all of my code samples and reference materials that I've been collecting for the past year or so… and the one that pisses me off the most, all the code I'd been working on since July for the next version of my website.

When I mentioned it to my friend Ben, he said “What a bastard !! Oh well, at least your ADSL's working now, right ?”. Not meaning to have a go at Ben here now, but yes – I believe the ADSL's working. However, now I don't have a working laptop to make use of the internet with, and if the last time I sent it away for repair's anything to go by, I suspect I'm not going to get it back until late January. So here I am, having just been forced to shell out an extra £70 to get reconnected to ADSL after that cockup with BT, and paying £30/month for the privelege of broadband, and now I don't have a sodding PC to use it with !! It's really not all that funny! In fact, as Eugene doesn't have a wireless card in his Mac yet, he can't use broadband either – so we've got a lovely fast internet connection, and NOBODY's got any way of accessing it !

Why in god's name can't things just WORK ?